Jump to content

Default language for spell check


Erklitt

Recommended Posts

Since I'm asking about tech problems, here's another one:

This edit window refuses to realize I'm writing in English here. Most other programs I use will adept after a few words, but this editor never stops trying to change as many words to German as it can (capitalizing about every other word and completely changing some) - I have to change them back all the time. Do you know where I can set the default language that will be used by this edit window without changing my whole Windows language? (I use Windows 7) Or at least deactivate the whole spell check? Maybe there's somewhere on the control panel? Couldn't find it myself, but that would be a great help!!

Link to comment
Share on other sites

Mostly MS Internet Explorer 11; sometimes that has quirks and I go to Firefox (currently 46.0.1). But I couldn't find any language setting in iexplore menu - maybe I overlooked something?

Edit:
My html-editor for iexpore is set to Word. Just tried changing 'edit language' in Word options to English, that wasn't enough. But maybe somewhere near there?
PS: Word 2010
PPS: In Word, I've completely disabled instant spell check on entering text

Edited by Erklitt
Link to comment
Share on other sites

@Mestiv, @Kaymyth Thanks both of you for trying to help!

I probably didn't describe it clearly enough. Let me elaborate a little:

I have searched through the options in my browser (Internet Explorer 11). In those browser settings

  • there is a 'languages' button, but that setting seems to be only for filtering web pages. I've set this to German and English.
  • Then there is one that chooses the editor for html editing, which is set to Word. (As this is the only thing I can find even closely resembling some choice of edit settings for my browser, I had some hope that Word settings might help. It seems they don't.)
  • I can find no other place in Internet Explorer where I can set anything like 'edit language' or spell checking options.

This set me thinking maybe there is something system wide outside the browser. But maybe this site just uses the OS language. In that case I guess I'll just have to edit my posts somewhere else and paste them in.

If you have any more ideas, they will be welcome!

Link to comment
Share on other sites

My suspicion is your system language has changed. Look at the bottom right hand corner of your screen, where the time/date and notification areas are. There should be a thing that says 'Deutch' or something indicating that it's set to the German language. That needs to be changed to English.

Edit: Alternatively, try pressing "LeftAlt + Shift". That should cycle through the installed languages on your computer. 

Edit 2: Right, you don't want to change your system language... (Maybe I should actually have read all of what you said, hey?) Hmm... the shortcut should let you quickly swap between languages. I'll see if I can find anything better...

Edit 3: Changing that is your input language as opposed to the system language that everything else would be displayed in, so I'm re-revising my response to being that's probably what you want to change...

Edited by Haelbarde
Link to comment
Share on other sites

@Haelbarde Trying now... well, this changed my keyboard, but the spell check language is still English. Thanks anyway!

[Edit] Did a Little more Research. I would even temporarily Change my OS language while I'm on the shard if that is what it takes. But for changing the Display language it seems you Need Win 7 Ultimate or Enterprise, Win 7 Pro is not enough. So that Option is out.

(This by the way is what a text Looks like when I don't take Bach the changes the Editor has made for me.)

Edited by Erklitt
Link to comment
Share on other sites

15 minutes ago, Erklitt said:

@Haelbarde Trying now... well, this changed my keyboard, but the spell check language is still English. Thanks anyway!

Did you mean that it's still German? Anyway, I'm not sure... Right-clicking the textbox in Google Chrome gives me the option to change the Spell Check language, but that doesn't seem to be an option on IE, and I don't have Firefox installed atm...

Link to comment
Share on other sites

8 minutes ago, Haelbarde said:

What does it appear as under addons? Curious in case I run into this problem in the future, but I couldn't see anything in addons at a glance.

This is the site I found:
http://superuser.com/questions/439517/disable-spell-checking-in-ie-10-11-on-windows-7-8-8-1
and what it looked like on my system (except for German menus of course).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...